Cannot Install Layer SDK On VS Code WSL Remote

Hi,

I am trying to install the Layer (layer-sdk) on my computer (WSL Ubuntu 18.4, Py 3.8) using pip but this is the error I am getting:

`Could not find a version that satisfies the requirement layer-sdk (from versions: )
No matching distribution found for layer-sdk`

Any thoughts?

Have you tried running it with sudo?

Also, I found that Ubuntu v20+ behaved a bit better than v18.x when I installed the SDK.

1 Like

Hey @Stephen_Oladele, just checking in to see if you had any success with sudo.

Hi Diana,

I figured it out somehow on Ubuntu 18.04 by using the --upgrade flag.

Hi Volkan,

I figured it out somehow on Ubuntu 18.04 by using the --upgrade flag. I did not try using sudo; I used pip instead.

Awesome, thanks for the update! I will close this topic in that case.