Error while running "layer run" on PyCharm

Hello,

When I open a terminal inside PyCharm and run the layer run command, I got the following:

(base) C:\Users\ersoyp\Documents\LAYER\layer-examples-main\titanic>layer run
Layer 0.6.5 using https://beta.layer.co
No project found. Please initialize a new project by running `layer init`.

(base) C:\Users\ersoyp\Documents\LAYER\layer-examples-main\titanic>layer init
Missing parameter: template

Am I missing any point before running this command?

Thanks in advance.

We are deprecating layer init and will move to layer create. Update is on its way!

Meanwhile, you can do layer init titanic and use the initialized directory as a template for your own project.

Hello,

Thank you so much for the information! I have just tried it and got the following warning:

(base) C:\Users\ersoyp\Documents\LAYER\layer-examples-main\titanic>layer init titanic
copytree() got an unexpected keyword argument 'dirs_exist_ok'

Do I need to wait for the layer create an update or is there anything I can do not to get this message?

Can you please try running layer init titanic in a new empty directory?

Hello,

I opened a new project that is independent of the titanic directory and selected the same python environment that supports layer-sdk. I still get the same error.

(base) C:\Users\ersoyp\PycharmProjects\TestDirectory>layer init titanic
copytree() got an unexpected keyword argument 'dirs_exist_ok'

Ok, can you make sure your Python Version >=3.8 in that Pycharm environment?

Hello,

The Python version that the layer-sdk was installed was 3.7.6 which is the latest version of Python that Anaconda supports. So I could be able to install layer-sdk on this version.

I also have a Python 3.8 version that is installed on Windows 10, and I tried to install layer-sdk on it. However, I get the following error:

    Running setup.py install for brotlipy ... error
    ERROR: Command errored out with exit status 1:
     command: 'C:\Users\ersoyp\Anaconda3\envs\py38\python.exe' -u -c 'import io, os, sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\Users\\ersoyp\\AppData\\Local\\Temp\\pip-install-619zgx0d\\brotlipy_549b3d5bf5de4c95b57aac33f36d039b\\setup.py'"'"'; __file__='"'"'C:\\Users\\ersoyp\\AppData\\Local\\Temp\\pip-install-619zgx0d\\brotlipy_549b3d5bf5de4c95b57aac33f36d039b\\setup.py'"'"';f = getattr(tokenize, '"'"'open'"'"', open)(__file__) if os.path.exists(__file__) else io.StringIO('"'"'from setuptools import setup; setup()'"'"');code = f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record 'C:\Users\ersoyp\AppData\Local\Temp\pip-record-j_75gfbo\install-record.txt' --single-version-externally-managed --compile --install-headers 'C:\Users\ersoyp\Anaconda3\envs\py38\Include\brotlipy'
         cwd: C:\Users\ersoyp\AppData\Local\Temp\pip-install-619zgx0d\brotlipy_549b3d5bf5de4c95b57aac33f36d039b\
    Complete output (12 lines):
    running install
    running build
    running build_py
    creating build
    creating build\lib.win-amd64-3.8
    creating build\lib.win-amd64-3.8\brotli
    copying src\brotli\brotli.py -> build\lib.win-amd64-3.8\brotli
    copying src\brotli\build.py -> build\lib.win-amd64-3.8\brotli
    copying src\brotli\__init__.py -> build\lib.win-amd64-3.8\brotli
    running build_clib
    building 'libbrotli' library
    error: Microsoft Visual C++ 14.0 or greater is required. Get it with "Microsoft C++ Build Tools": https://visualstudio.microsoft.com/visual-cpp-build-tools/
    ----------------------------------------
ERROR: Command errored out with exit status 1: 'C:\Users\ersoyp\Anaconda3\envs\py38\python.exe' -u -c 'import io, os, sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\Users\\ersoyp\\AppData\\Local\\Temp\\pip-install-619zgx0d\\brotlipy_549b3d5bf5de4c95b57aac33f36d039b\\setup.py'"'"'; __file__='"'"'C:\\Users\\ersoyp\\AppData\\Local\\Temp\\pip-install-619zgx0d\\brotlipy_549b3d5bf5de4c95b57aac33f36d039b\\setup.py'"'"';f = getattr(tokenize, '"'"'open'"'"', open)(__file__) if os.path.exists(__file__) else io.StringIO('"'"'from setuptools import setup; setup()'"'"');code = f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record 'C:\Users\ersoyp\AppData\Local\Temp\pip-record-j_75gfbo\install-record.txt' --single-version-externally-managed --compile --install-headers 'C:\Users\ersoyp\Anaconda3\envs\py38\Include\brotlipy' Check the logs for full command output.

You need at least Python 3.8 to be able to use Layer SDK.

And about the Windows 10 issue, looks like you are missing some libraries. You can try the solution mentioned here:

Thank you so much for the solution! I installed the packages that are provided in the link. I finally installed successfully layer-sdk to python 3.8 environment.

Building wheels for collected packages: brotlipy
  Building wheel for brotlipy (setup.py) ... done
  Created wheel for brotlipy: filename=brotlipy-0.7.0-cp38-cp38-win_amd64.whl size=376306 sha256=4c2e9ce3c7dd7a54312ae18513433d54a26de76470826564825da9910b82ee8c
  Stored in directory: c:\users\ersoyp\appdata\local\pip\cache\wheels\cf\1a\c2\6960e0438c1b79edcee75bc8a2a34e972a93ef5738f8e28e03
Successfully built brotlipy
Installing collected packages: botocore, brotlipy, alembic, aiohttp, aiodns, validate-email, transformers, rich, pyjwt, pyarrow, prompt-toolkit, polling, networkx, mlflow, grpcio-tools, cryptography, boto3, aiodocker
  Attempting uninstall: botocore
    Found existing installation: botocore 1.20.97
    Uninstalling botocore-1.20.97:
      Successfully uninstalled botocore-1.20.97
Successfully installed aiodns-3.0.0 aiodocker-0.19.1 aiohttp-3.7.4.post0 alembic-1.4.1 boto3-1.17.98 botocore-1.20.98 brotlipy-0.7.0 cryptography-3.4.7 grpcio-tools-1.38.0 mlflow-1.18.0 networkx-2.5.1 polling-0.3.2 prompt-toolkit-3.0.19 pyarrow-4.0.1 pyjwt-1.7.1 rich-10.4.0 transformers-4.7.0 validate-email-1.3

(py38) C:\Users\ersoyp>python --version
Python 3.8.10

With the 3.8 environment that has layer-sdk installed, I tried to run the command layer init titanic and got the following warning.

(py38) C:\Users\ersoyp\PycharmProjects\TestDirectory>layer init titanic
'layer' is not recognized as an internal or external command,
operable program or batch file.

(py38) C:\Users\ersoyp\PycharmProjects\TestDirectory>

In that terminal, can you run to make sure layer-sdk is installed.

pip freeze | findstr "layer"
1 Like

Hello,
I have just run the command you provided.

image

image

But after I run the command layer init titanic, I get the following error:

(py38) C:\Users\ersoyp\PycharmProjects\TestDirectory>pip freeze | findstr "layer"
layer-sdk==0.6.5

(py38) C:\Users\ersoyp\PycharmProjects\TestDirectory>layer init titanic
'layer' is not recognized as an internal or external command,
operable program or batch file.

Since it’s a PyCharm context console, perhaps layer is not in the Path of that environment. You can try re-installing layer-sdk in the PyCharm console or using Layer in a console outside of PyCharm

Hello,

I tried to install layer-sdk by using the PyCharm environment with the Python 3.8 version. Since it seems that it is already installed, I couldn’t reinstall it again.

Also, I used terminal inside of PyCharm to reinstall it again; however it logs as “Requirement already satisfied”


(py38) C:\Users\ersoyp\PycharmProjects\TestDirectory>pip install --upgrade layer-sdk
Requirement already satisfied: layer-sdk in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (0.6.5)
Requirement already satisfied: grpcio-tools>=1.37.1 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (1.38.0)
Requirement already satisfied: pyarrow>=4.0.0 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (4.0.1)
Requirement already satisfied: pyyaml>=5.3.1 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (5.4.1)
Requirement already satisfied: pyjwt<2.0.0,>=1.7.1 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (1.7.1)
Requirement already satisfied: aiodocker>=0.19.1 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (0.19.1)
Requirement already satisfied: idna<3 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (2.10)
Requirement already satisfied: pandas>=1.1.2 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (1.2.4)
Requirement already satisfied: yarl>=1.6.3 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (1.6.3)
Requirement already satisfied: pyspark>=3.0.1 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (3.1.1)
Requirement already satisfied: polling>=0.3.1 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (0.3.2)
Requirement already satisfied: rich>=9.10.0 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (10.4.0)
Requirement already satisfied: protobuf>=3.12.0 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (3.17.0)
Requirement already satisfied: transformers in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (4.7.0)
Requirement already satisfied: networkx>=2.5 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (2.5.1)
Requirement already satisfied: aiohttp[speedups]>=3.7.3 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (3.7.4.post0)
Requirement already satisfied: prompt-toolkit>=3.0.8 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (3.0.19)
Requirement already satisfied: mlflow>=1.15.0 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (1.18.0)
Requirement already satisfied: Jinja2>=2.11.3 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (2.11.3)
Requirement already satisfied: cryptography>=3.4.7 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (3.4.7)
Requirement already satisfied: boto3>=1.16.24 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (1.17.98)
Requirement already satisfied: click>=7.1.2 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (7.1.2)
Requirement already satisfied: validate-email==1.3 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from layer-sdk) (1.3)
Requirement already satisfied: typing-extensions>=3.6.5 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from aiodocker>=0.19.1->layer-sdk) (3.10.0.0)
Requirement already satisfied: multidict<7.0,>=4.5 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from aiohttp[speedups]>=3.7.3->layer-sdk) (5.1.0)
Requirement already satisfied: chardet<5.0,>=2.0 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from aiohttp[speedups]>=3.7.3->layer-sdk) (4.0.0)
Requirement already satisfied: async-timeout<4.0,>=3.0 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from aiohttp[speedups]>=3.7.3->layer-sdk) (3.0.1)
Requirement already satisfied: attrs>=17.3.0 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from aiohttp[speedups]>=3.7.3->layer-sdk) (21.2.0)
Requirement already satisfied: cchardet in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from aiohttp[speedups]>=3.7.3->layer-sdk) (2.1.7)
Requirement already satisfied: brotlipy in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from aiohttp[speedups]>=3.7.3->layer-sdk) (0.7.0)
Requirement already satisfied: aiodns in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from aiohttp[speedups]>=3.7.3->layer-sdk) (3.0.0)
Requirement already satisfied: botocore<1.21.0,>=1.20.98 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from boto3>=1.16.24->layer-sdk) (1.20.98)
Requirement already satisfied: s3transfer<0.5.0,>=0.4.0 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from boto3>=1.16.24->layer-sdk) (0.4.2)
Requirement already satisfied: jmespath<1.0.0,>=0.7.1 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from boto3>=1.16.24->layer-sdk) (0.10.0)
Requirement already satisfied: urllib3<1.27,>=1.25.4 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from botocore<1.21.0,>=1.20.98->boto3>=1.16.24->layer-sdk) (1.26.4)
Requirement already satisfied: python-dateutil<3.0.0,>=2.1 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from botocore<1.21.0,>=1.20.98->boto3>=1.16.24->layer-sdk) (2.8.1)
Requirement already satisfied: cffi>=1.12 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from cryptography>=3.4.7->layer-sdk) (1.14.5)
Requirement already satisfied: pycparser in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from cffi>=1.12->cryptography>=3.4.7->layer-sdk) (2.20)
Requirement already satisfied: setuptools in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from grpcio-tools>=1.37.1->layer-sdk) (52.0.0.post20210125)
Requirement already satisfied: grpcio>=1.38.0 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from grpcio-tools>=1.37.1->layer-sdk) (1.38.0)
Requirement already satisfied: six>=1.5.2 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from grpcio>=1.38.0->grpcio-tools>=1.37.1->layer-sdk) (1.16.0)
Requirement already satisfied: MarkupSafe>=0.23 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from Jinja2>=2.11.3->layer-sdk) (2.0.1)
Requirement already satisfied: databricks-cli>=0.8.7 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from mlflow>=1.15.0->layer-sdk) (0.14.3)
Requirement already satisfied: requests>=2.17.3 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from mlflow>=1.15.0->layer-sdk) (2.25.1)
Requirement already satisfied: querystring-parser in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from mlflow>=1.15.0->layer-sdk) (1.2.4)
Requirement already satisfied: prometheus-flask-exporter in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from mlflow>=1.15.0->layer-sdk) (0.18.2)
Requirement already satisfied: Flask in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from mlflow>=1.15.0->layer-sdk) (1.1.4)
Requirement already satisfied: packaging in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from mlflow>=1.15.0->layer-sdk) (20.9)
Requirement already satisfied: gitpython>=2.1.0 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from mlflow>=1.15.0->layer-sdk) (3.1.17)
Requirement already satisfied: sqlparse>=0.3.1 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from mlflow>=1.15.0->layer-sdk) (0.4.1)
Requirement already satisfied: entrypoints in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from mlflow>=1.15.0->layer-sdk) (0.3)
Requirement already satisfied: numpy in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from mlflow>=1.15.0->layer-sdk) (1.20.3)
Requirement already satisfied: waitress in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from mlflow>=1.15.0->layer-sdk) (2.0.0)
Requirement already satisfied: docker>=4.0.0 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from mlflow>=1.15.0->layer-sdk) (5.0.0)
Requirement already satisfied: pytz in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from mlflow>=1.15.0->layer-sdk) (2021.1)
Requirement already satisfied: alembic<=1.4.1 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from mlflow>=1.15.0->layer-sdk) (1.4.1)
Requirement already satisfied: cloudpickle in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from mlflow>=1.15.0->layer-sdk) (1.6.0)
Requirement already satisfied: sqlalchemy in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from mlflow>=1.15.0->layer-sdk) (1.4.15)
Requirement already satisfied: python-editor>=0.3 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from alembic<=1.4.1->mlflow>=1.15.0->layer-sdk) (1.0.4)
Requirement already satisfied: Mako in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from alembic<=1.4.1->mlflow>=1.15.0->layer-sdk) (1.1.4)
Requirement already satisfied: tabulate>=0.7.7 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from databricks-cli>=0.8.7->mlflow>=1.15.0->layer-sdk) (0.8.9)
Requirement already satisfied: websocket-client>=0.32.0 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from docker>=4.0.0->mlflow>=1.15.0->layer-sdk) (1.0.1)
Requirement already satisfied: pywin32==227 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from docker>=4.0.0->mlflow>=1.15.0->layer-sdk) (227)
Requirement already satisfied: gitdb<5,>=4.0.1 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from gitpython>=2.1.0->mlflow>=1.15.0->layer-sdk) (4.0.7)
Requirement already satisfied: smmap<5,>=3.0.1 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from gitdb<5,>=4.0.1->gitpython>=2.1.0->mlflow>=1.15.0->layer-sdk) (4.0.0)
Requirement already satisfied: decorator<5,>=4.3 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from networkx>=2.5->layer-sdk) (4.4.2)
Requirement already satisfied: wcwidth in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from prompt-toolkit>=3.0.8->layer-sdk) (0.2.5)
Requirement already satisfied: py4j==0.10.9 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from pyspark>=3.0.1->layer-sdk) (0.10.9)
Requirement already satisfied: certifi>=2017.4.17 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from requests>=2.17.3->mlflow>=1.15.0->layer-sdk) (2020.12.5)
Requirement already satisfied: pygments<3.0.0,>=2.6.0 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from rich>=9.10.0->layer-sdk) (2.9.0)
Requirement already satisfied: colorama<0.5.0,>=0.4.0 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from rich>=9.10.0->layer-sdk) (0.4.4)
Requirement already satisfied: commonmark<0.10.0,>=0.9.0 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from rich>=9.10.0->layer-sdk) (0.9.1)
Requirement already satisfied: greenlet!=0.4.17 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from sqlalchemy->mlflow>=1.15.0->layer-sdk) (1.1.0)
Requirement already satisfied: pycares>=4.0.0 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from aiodns->aiohttp[speedups]>=3.7.3->layer-sdk) (4.0.0)
Requirement already satisfied: Werkzeug<2.0,>=0.15 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from Flask->mlflow>=1.15.0->layer-sdk) (1.0.1)
Requirement already satisfied: itsdangerous<2.0,>=0.24 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from Flask->mlflow>=1.15.0->layer-sdk) (1.1.0)
Requirement already satisfied: pyparsing>=2.0.2 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from packaging->mlflow>=1.15.0->layer-sdk) (2.4.7)
Requirement already satisfied: prometheus-client in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from prometheus-flask-exporter->mlflow>=1.15.0->layer-sdk) (0.10.1)
Requirement already satisfied: regex!=2019.12.17 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from transformers->layer-sdk) (2021.4.4)
Requirement already satisfied: tokenizers<0.11,>=0.10.1 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from transformers->layer-sdk) (0.10.3)
Requirement already satisfied: huggingface-hub==0.0.8 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from transformers->layer-sdk) (0.0.8)
Requirement already satisfied: tqdm>=4.27 in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from transformers->layer-sdk) (4.61.1)
Requirement already satisfied: sacremoses in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from transformers->layer-sdk) (0.0.45)
Requirement already satisfied: filelock in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from transformers->layer-sdk) (3.0.12)
Requirement already satisfied: joblib in c:\users\ersoyp\anaconda3\envs\py38\lib\site-packages (from sacremoses->transformers->layer-sdk) (1.0.1)

(py38) C:\Users\ersoyp\PycharmProjects\TestDirectory>

Hey Pinar,

What happens when you open a python prompt? And can you try running import layer from within the Python prompt and send the output here?

Thanks!
Volkan

Hi Volkan,

Thanks for your suggestion!

In PyCharm environment, I can see that layer-sdk is installed. However, when I tried to import layer with python prompt, I get the following error:

image

installed the layer-sdk package by using Anaconda prompt by choosing python 3.8 environment. Do I need to reinstall layer by using python prompt, too? I

Hello Alex,

I chose Python 3.8 as the Project Interpreter instead of Conda env and installed layer-sdk version 0.6.6 manually.

After that, I typed layer init in the terminal and got the following error:

image.png

But then I tried it on a separate Python Prompt environment and successfully run import run there:

image.png

From this point on, how I can run the titanic project?

Thanks in advance!

Alex Haak via Layer Declarative MLOps <layer@discoursemail.com>, 30 Haz 2021 Çar, 14:29 tarihinde şunu yazdı: