Failed to build featureset

I am running “layer run” and the error says “Failed to build featureset”. I am using the house_prices dataset. Any solution to this?

Hi @vish0399

Can you please share complete layer run output. We will take a look on our side and update.

It is working with latest layer client.

I am using layer client 0.6.7 please upgrade your client using below command if needed.

pip install --upgrade layer-sdk


Even after updating i am getting the same error. I actually changed from sklearn model to keras model. Could it be any issue with my code?

@vish0399 It could be can you please share the diff of changes you have made. Meanwhile we will also check on our side if we see any issue.

This is the Google drive link to my project : Layer-House-Prices-main.zip - Google Drive

This is the code to my kaggle notebook : Fork of housing_prices | Kaggle

@vish0399 Can you once try to run the code at GitHub - mwitiderrick/Layer-House-Prices: Layer House Prices as is that way we can be sure that issue is because of your changes. Also when I ran the code shared by you it fails in model stage because of code errors and not in featureset stage.

I tried running the original code from the GitHub repo. It gives me the same error.

Hi @vish0399,

We were able to reproduce the issue and it will be fixed in the next release.

Meanwhile, we fixed your account and if you can logout and login again, you will be able to run your project.

I logged out and logged in to my account again, but it still gives the same error.

Could you please try these in terminal:

layer logout
layer login
layer run

I did the same because you instructed me to do the same before. Still gives the same error.

I updated the Layer SDK to the latest version and still, the issue persists with the same error message “Failed to build feature set”.

To close the loop - this problem was because we had an issue on the Layer side with database access permissions. This was fixed on the backend and the issue was resolved.